[WARNING]: Could not match supplied host pattern, ignoring: unprovisioned
[WARNING]: Found variable using reserved name: hosts

PLAY [Deploy initial device configuration] *************************************

TASK [Set variables that cannot be set with VARS] ******************************
ok: [probe]
ok: [dut]

TASK [Find device readiness script] ********************************************
ok: [probe]
ok: [dut]

TASK [Wait for device to become ready] *****************************************
skipping: [dut]
skipping: [probe]

TASK [Normalize config on bridge-like devices] *********************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-module.yml for dut, probe

TASK [Figure out whether to deploy the module normalize on current device] *****
ok: [probe]
ok: [dut]

TASK [Find configuration template for normalize] *******************************
ok: [probe]
ok: [dut]

TASK [fail] ********************************************************************
skipping: [dut]
skipping: [probe]

TASK [Find configuration deployment deploy_script for normalize] ***************
ok: [probe]
ok: [dut]

TASK [Print deployed configuration when running in verbose mode] ***************
skipping: [dut]
skipping: [probe]

TASK [Deploy normalize configuration] ******************************************
skipping: [dut]
skipping: [probe]

TASK [Deploy initial configuration] ********************************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-module.yml for dut, probe

TASK [Figure out whether to deploy the module initial on current device] *******
ok: [probe]
ok: [dut]

TASK [Find configuration template for initial] *********************************
ok: [probe]
ok: [dut]

TASK [fail] ********************************************************************
skipping: [dut]
skipping: [probe]

TASK [Find configuration deployment deploy_script for initial] *****************
ok: [probe]
ok: [dut]

TASK [Print deployed configuration when running in verbose mode] ***************
ok: [probe] => 
  msg: |-
    initial configuration for probe
    =========================================
    #!/bin/bash
    #
    set -e
    set -x
    #
    # Create bash profile script
    #
    cat <<SCRIPT >/root/.bash_profile
    #!/bin/bash
    #
    export PS1="\h(bash)# "
    echo
    echo "Use vtysh to connect to FRR daemon"
    echo
    SCRIPT
    #
    # Get the current next hop for the default route
    #
    def_nh=$(ip route list default|awk '{ print $3 }')
    #
    # Create the management VRF and add eth0 to it
    #
    if [ ! -e /sys/devices/virtual/net/mgmt ]; then
      ip link add mgmt type vrf table 42
    fi
    ip link set mgmt up
    sysctl -qw net.ipv6.conf.eth0.keep_addr_on_down=1
    ip link set eth0 master mgmt
    #
    # Reinstall the default route if we had it before
    #
    if [[ -n "$def_nh" ]]; then
      ip route add 0.0.0.0/0 vrf mgmt via $def_nh
    fi
    #
    # Enable FRR modules (if not using containerlab bind-mounted /etc/frr/daemons)
    #
  
    #
    # Create loopbacks, stub and lag/bond devices
    #
    if [ ! -e /sys/class/net/lo ]; then
      if [ ! -e /sys/devices/virtual/net/lo ]; then
        ip link add lo type dummy
        ip link set dev lo up
      fi
    fi
  
    # Disable IPv6 (for IPv4-only interfaces) or SLAAC (if the device is a router)
    #
    sysctl -qw net.ipv6.conf.eth1.disable_ipv6=1
    ip link set dev eth1 mtu 1500
  
    #
    # Add vtysh.conf file
    echo "service integrated-vtysh-config" >/etc/frr/vtysh.conf
  
    #
    # Rest of initial configuration done through VTYSH
    #
    cat >/tmp/config <<CONFIG
    hostname probe
    !
    vrf mgmt
     exit-vrf
    !
    frr defaults datacenter
    !
    interface lo
     no shutdown
     ip address 10.0.0.2/32
    !
    interface eth1
     no shutdown
     description probe -> dut [external]
     ip address 10.1.0.2/30
    !
    do write
    CONFIG
    vtysh -f /tmp/config
    exit 0
ok: [dut] => 
  msg: |-
    initial configuration for dut
    =========================================
    hostname dut
    !
    lldp enable
    !
    !
    ip host probe 10.0.0.2
    !
    !
    default mtu 1532
    !
    interface loopback0
     ip address 10.0.0.1/32
     no ipv6 enable
    !
    interface mgmt1/1/1
     no lldp transmit
     no lldp receive
    !
    interface ethernet1/1/1
     no shutdown
     no switchport
     description "dut -> probe [external]"
     ip address 10.1.0.1/30
     ip unreachables
     no ipv6 enable
    !

TASK [Deploy initial configuration] ********************************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-config/dellos10.yml for dut
included: /home/pipi/netlab_gh/netsim/ansible/tasks/frr/initial-clab.yml for probe

TASK [wait_for_connection] *****************************************************
skipping: [dut]

TASK [dellos10_config: deploying initial from /home/pipi/netlab_gh/netsim/ansible/templates/initial/dellos10.j2, save to startup=yes] ***
changed: [dut]

TASK [Attempt to load VRF kernel module] ***************************************
changed: [probe -> localhost]

TASK [Disable FRR management VRF when modprobe fails] **************************
skipping: [probe]

TASK [include_tasks] ***********************************************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/frr/deploy-config.yml for probe

TASK [template] ****************************************************************
changed: [probe]

TASK [set_fact] ****************************************************************
ok: [probe]

TASK [run /tmp/config.sh to deploy initial config from /home/pipi/netlab_gh/netsim/ansible/templates/initial/frr.j2] ***
changed: [probe]

TASK [run vtysh to import initial config from /home/pipi/netlab_gh/netsim/ansible/templates/initial/frr.j2] ***
skipping: [probe]

PLAY [Deploy module-specific configurations] ***********************************

TASK [Set variables that cannot be set with VARS] ******************************
ok: [probe]
ok: [dut]

TASK [Deploy individual configuration modules] *********************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-module.yml for dut, probe => (item=routing)
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-module.yml for dut, probe => (item=bgp)

TASK [Figure out whether to deploy the module routing on current device] *******
ok: [probe]
ok: [dut]

TASK [Find configuration template for routing] *********************************
ok: [probe]
ok: [dut]

TASK [fail] ********************************************************************
skipping: [dut]
skipping: [probe]

TASK [Find configuration deployment deploy_script for routing] *****************
ok: [probe]
ok: [dut]

TASK [Print deployed configuration when running in verbose mode] ***************
ok: [probe] => 
  msg: |-
    routing configuration for probe
    =========================================
    !
    !
ok: [dut] => 
  msg: |-
    routing configuration for dut
    =========================================
    !
    !
    route-map set_comm-ipv4 permit 10
      set community 65000:101
  
    !
    ! AS-path access lists
    !
    !
    ! Static routes (dual routes for each entry, in entry VRF and next hop VRF)
    !

TASK [Deploy routing configuration] ********************************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-config/dellos10.yml for dut
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-config/frr.yml for probe

TASK [wait_for_connection] *****************************************************
skipping: [dut]

TASK [dellos10_config: deploying routing from /home/pipi/netlab_gh/netsim/ansible/templates/routing/dellos10.j2, save to startup=yes] ***
changed: [dut]

TASK [template] ****************************************************************
changed: [probe]

TASK [set_fact] ****************************************************************
ok: [probe]

TASK [run /tmp/config.sh to deploy routing config from /home/pipi/netlab_gh/netsim/ansible/templates/routing/frr.j2] ***
skipping: [probe]

TASK [run vtysh to import routing config from /home/pipi/netlab_gh/netsim/ansible/templates/routing/frr.j2] ***
changed: [probe]

TASK [Figure out whether to deploy the module bgp on current device] ***********
ok: [probe]
ok: [dut]

TASK [Find configuration template for bgp] *************************************
ok: [probe]
ok: [dut]

TASK [fail] ********************************************************************
skipping: [dut]
skipping: [probe]

TASK [Find configuration deployment deploy_script for bgp] *********************
ok: [probe]
ok: [dut]

TASK [Print deployed configuration when running in verbose mode] ***************
ok: [probe] => 
  msg: |-
    bgp configuration for probe
    =========================================
    !
    router bgp 65100
      no bgp ebgp-requires-policy
      no bgp default ipv4-unicast
      bgp default show-hostname
      bgp default show-nexthop-hostname
  
      ! Consider AS paths of same length but with different AS as ECMP candidates
      bgp bestpath as-path multipath-relax
  
      bgp router-id 10.0.0.2
    !
      neighbor 10.1.0.1 remote-as 65000
      neighbor 10.1.0.1 description dut
    !
     address-family ipv4 unicast
    !
  
    !
      network 10.0.0.2/32
    !
    !
    !
      neighbor 10.1.0.1 activate
      no neighbor 10.1.0.1 send-community all
      neighbor 10.1.0.1 send-community standard
      neighbor 10.1.0.1 send-community large
    !
    !
    !
    do write
ok: [dut] => 
  msg: |-
    bgp configuration for dut
    =========================================
    !
    router bgp 65000
      log-neighbor-changes
  
    ! define a generic unnumbered template to be used for eBGP unnumbered...
    ! additionally, need to define link-local-only-nexthop as per Dell suggested "Cumulus workaround"
    ! WTF Dell...
      template unnumbered_ebgp
        link-local-only-nexthop
        exit
  
      router-id 10.0.0.1
    !
      neighbor 10.1.0.2
        remote-as 65100
  
        description "probe"
        send-community standard
  
    !
     address-family ipv4 unicast
       soft-reconfiguration inbound
       activate
     exit
  
  
      timers 3 9
      advertisement-interval 1
      no shutdown
      exit
    !
    !
     address-family ipv4 unicast
    !
      network 10.0.0.1/32
    !
    !
    !
    !

TASK [Deploy bgp configuration] ************************************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-config/dellos10.yml for dut
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-config/frr.yml for probe

TASK [wait_for_connection] *****************************************************
skipping: [dut]

TASK [dellos10_config: deploying bgp from /home/pipi/netlab_gh/netsim/ansible/templates/bgp/dellos10.j2, save to startup=yes] ***
changed: [dut]

TASK [template] ****************************************************************
changed: [probe]

TASK [set_fact] ****************************************************************
ok: [probe]

TASK [run /tmp/config.sh to deploy bgp config from /home/pipi/netlab_gh/netsim/ansible/templates/bgp/frr.j2] ***
skipping: [probe]

TASK [run vtysh to import bgp config from /home/pipi/netlab_gh/netsim/ansible/templates/bgp/frr.j2] ***
changed: [probe]

PLAY [Deploy custom deployment templates] **************************************

TASK [Run custom configuration deployment scripts] *****************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-custom-config.yml for dut => (item=bgp.policy)

TASK [Find configuration template] *********************************************
ok: [dut]

TASK [fail] ********************************************************************
skipping: [dut]

TASK [Check is the configuration template is a file] ***************************
ok: [dut -> localhost]

TASK [fail] ********************************************************************
skipping: [dut]

TASK [Process template /home/pipi/netlab_gh/netsim/extra/bgp.policy/dellos10.j2 for dut] ***
skipping: [dut]

TASK [Find custom configuration deployment script] *****************************
ok: [dut]

TASK [Run the configuration deployment script] *********************************
included: /home/pipi/netlab_gh/netsim/ansible/tasks/deploy-config/dellos10.yml for dut

TASK [wait_for_connection] *****************************************************
skipping: [dut]

TASK [dellos10_config: deploying bgp.policy from /home/pipi/netlab_gh/netsim/extra/bgp.policy/dellos10.j2, save to startup=yes] ***
changed: [dut]

PLAY RECAP *********************************************************************
dut                        : ok=34   changed=4    unreachable=0    failed=0    skipped=14   rescued=0    ignored=0   
probe                      : ok=36   changed=7    unreachable=0    failed=0    skipped=11   rescued=0    ignored=0   



Use this topology to test 'set.community.standard' route-map option.